Some customers were experiencing slow balance responses and issues canceling orders.
Incident Report for Tradier
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 16:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2020 - 16:07 EDT
This incident affected: Trading and Balances.