Some customers are experiencing slow balance responses and issues placing orders.
Incident Report for Tradier
Resolved
This incident has been resolved.

We're continuing our investigation into the issues we saw today. However, early analysis shows that account API related servers were unable to reach critical downstream systems due to underlying network failure.
Posted Nov 20, 2020 - 15:13 EST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2020 - 14:30 EST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2020 - 13:08 EST
Investigating
We are currently investigating this issue.
Posted Nov 20, 2020 - 13:03 EST
This incident affected: Trading, Balances, and Web Sites.