Some customers were facing issues with balances and trading
Incident Report for Tradier
Resolved
This incident has been resolved.
Posted Jan 29, 2021 - 09:48 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2021 - 09:41 EST
This incident affected: Trading and Balances.