Degrade Performance in Order Submission and Modification

Incident Report for Tradier

Resolved

Trading has been fully restored. If you need any assistance with a trade that was stuck during the partial outage, please reach out to the brokerage support team at service@tradierbrokerage.com or (980) 272-3880.
Posted Apr 16, 2026 - 12:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2026 - 12:49 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2026 - 12:47 EDT

Investigating

We are currently investigating this issue.
Posted Apr 16, 2026 - 12:36 EDT
This incident affected: Trading.